注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

太阳神上的博客

青青子衿,悠悠我心,但为君故,沉吟至今。

 
 
 

日志

 
 
 
 

成功安装GTK+-2.0  

2007-08-21 23:13:08|  分类: Linux使用札记 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

   前几天我从网上看到一篇非常精采的讲如何安装GTK+-2.0的文章,于是我想起以前安装GTK+-2.0失败的经历,于是根据这篇文章再次安装地GTK+-2.0来。
  原来开源社区是如此地活跃,我上次下载的安装包与现在GTK+的官方网站上的都不相同,不过下载也快,一则下载的只是源代码,二则下载时正是深夜,我用Opera下载,每秒一百二三十多k,发现用Opera下载居然比迅雷还快。GTK+-2.0所需要的包一共有五个,按照安装的顺序是glib,atk,cairo,pango和gtk+-2.0。这一次我也是看这篇文档才知道。
  我记得以前安装这个东西时,总是出现包的版本号太低,而且它还老提一个叫pkg-config的工具与PKG_CONFIG_PATH的环境变量,而且问题往往出现在那里。从那篇文章里,我终于明白的那个东西的用处,原来Linux里还有这样重要的编译工具,我搞了这么久的Linux居然还不知道。
  不过我在编译pango包时还是遇到一个一链接问题,后来通过修改LDFLAGS终于解决了。真麻烦,不知道为什么GTK+不做出一个统一的二进制包出来,它在Windows里提供的就方便多了,完全没这么复杂,和Windows里的一般应用程序一样,next步步下去就成了。也不知道搞Linux里那帮人为什么喜欢源码编译,脑子进水了。


  评论这张
 
阅读(342)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017